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1.

Setup Overview

(All you need to know about ThinManager in 100* words or less)
Build a terminal server with the Microsoft Windows 2003 Server operating
system. Enable Terminal Services. See Section 2.2.

Create a Microsoft Licensing Server and add a TS CAL (Terminal Server Client
Access License) for each thin client. They also require a normal CAL. See
Section 2.3.

Create a Microsoft user profile for each terminal on the terminal server. Make
sure that the user is a member of the Remote Desktop Users Windows group.
See Section 2.4.

Apply appropriate security to each user profile using the standard Microsoft
techniques.

Install ACP ThinManager software onto a computer to create a ThinManager
Server. See Section 5.2.

Install an ACP License for each ThinManager Ready thin client. See Section
6.5.

Establish the IP addressing scheme for the thin clients, Static IP or DHCP. See
Section 7.1.

If using DHCP, configure Option 066 to list the IP address of the ThinManager
Server. See Section 7.1.1.

Attach the terminals to ThinManager by either:

o Turning on the terminal and selecting the "Create New Terminal"
option when the offline terminals are listed.

o Pre-creating the terminals in ThinManager and selecting the proper
terminal name when the terminal is turned on and offline terminals are
listed.

The clients will connect to the ThinManager Server and download the
firmware and configuration. The configuration will send them to the terminal
server to login and start a session.

* Closer to 200
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2. Microsoft Terminal Services

2.1. Role of Terminal Server

A terminal server is a Windows 2003 that has terminal services enabled. This
configures the server to use a mainframe style client/server architecture. A client
logs into the terminal server and starts a session. Keystrokes and mouse movements
are sent from the client to the session on the terminal server. All processing takes
place on the terminal server and the resulting graphics are sent to the client for
display.

The ThinManager configuration sends the ThinManager Ready thin client to the
terminal server(s) to start a session(s).

2.2. Terminal Server Configuration
ThinManager Ready thin clients rely on Microsoft terminal servers.

U Build a Windows 2003 Server. A clean install is better than converting an
existing server.

U Enable Terminal Services in the Windows Components Wizard by selecting
Start> Control Panel> Add/Remove Programs> Add/Remove Windows
Components and checking the Terminal Services checkbox.

U Select the Permission Compatibility during the Terminal Services installation.
Most HMIs require the default Relaxed Security because the Full Security
setting requires users to have administrative rights. This can be changed in
the Server Settings of the Terminal Services Configuration Console (Section
2.5.2).

2.2.1. Virtual Memory

U Set the Virtual Memory page file to 2.5 times the size of the physical memory
to increase performance.

U  Go to Control Panel > System > the Advanced tab > Performance Settings to
launch the Performance Options.

U Select the Virtual Memory Change button on the Advanced tab.

L Set the Initial size and Maximum size to the same value to speed
performance.

U Changing the virtual memory requires a computer reboot.

2.3. Microsoft Licensing

Each terminal or user will require a CAL (Client Access License) and TSCAL (Terminal
Services Client Access License) to access the terminal servers. The TSCALs are not
pooled but allow connection to an unlimited number of terminal servers.

U Add a Terminal Services Licensing Server (TSLS) to the network by checking
the Terminal Server Licensing checkbox on the Windows Components page.
(Start> Control Panel> Add/Remove Programs> Add/Remove Windows
Components). This is not a separate piece of hardware but an application to
install and run on an existing server.
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U Microsoft normally recommends a single TSLS per network. They recommend
that it be installed on the Domain Controller, if available.
Windows 2003 SP1 and later have a License Server setting in the Server
Settings of the Terminal Services Configuration Console that allows multiple
TSLSs. See Server Settings in section 2.5.2 for details.

U Activate the TSLS by selecting Start>Programs>Administrative
Tools>Terminal Server Licensing on the Terminal Server Licensing Server and
selecting Action>Activate Server from the menu to launch the licensing
wizard. Follow Microsoft’s instructions.

U Activate the TSCALs on the TSLS through the licensing wizard following
Microsoft’s instructions.

Terminals will connect without a TSLS and receive a 90-day temporary TSCAL. When
this expires the terminal will display an “Unable to connect to terminal server” error
message in the top left corner of its monitor. The cause of the error, lack of a TSLS
and TSCALs, can be found in the terminal server event log where it will show a
“Client license is unable to be issued” error message. Add TSCALs to an activated
TSLS to solve this issue.

2.4. Microsoft Users

Terminals require a valid Windows user account to start a session on the terminal
servers. These can be domain accounts or local accounts on each terminal server.

U Create a unique user account for each terminal or user in the Computer
Management console (Start> Program Files> Administrative Tools> Computer
Management). Highlight the Users folder in System Tools/Local Users and
Groups and select Action> New User from the menu.

U Add the users to either the Remote Desktop Users group or the
Administrators group to allow access to the terminal server.

U Some HMIs also require that users be a member of the Power User group to
run successfully.

O Apply any group policies as needed.

U Windows 2003 activates a secure screen saver for each user by default
requiring CTL+ALT+TAB to unlock. Users of touch screens will want to
deactivate this, either in each user account or in the Group Policy Editor
(gpedit.msc) at User Configuration>Administrative Templates>Control
Panel>Display.
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2.5. Terminal Services Configuration

The Terminal Services Configuration console provides tools for configuring the
connection between terminals and the terminal server. These are a few of note:

2.5.1. Connections — RDP-tcp Properties

U Open the Terminal Services Configuration (Start> Program Files>
Administrative Tools> Terminal Services Configuration), highlight Connections
on the left and double-click on RDP-tcp on the right to launch the RDP-tcp
Properties page.

Allow Audio Mapping for Terminal Sound
U Sound redirection to terminals is turned off by default.

U Select the Client Settings tab and unselect Audio Mapping to allow sound to
be redirected to the terminal.

U Any users will need to log out and login to apply the change.

End Disconnected Sessions

Most users will want to keep disconnected sessions on the server to allow a user to
reconnect to an existing session.

Disconnected sessions can be deleted from the terminal server to reduce the
resource and to have terminals start fresh sessions when they reconnect.

U Select the Sessions tab, select the Override user settings and set the End a
disconnected session parameter.

U Any users will need to log out and login to apply the change.

2.5.2. Server Settings

U Open the Terminal Services Configuration (Start> Program Files>
Administrative Tools> Terminal Services Configuration), highlight Server
Settings on the left.

License Server Discovery

Microsoft recommends a single Terminal Services License Server (TSLS) on a
network. Having multiple TSLSs can cause the terminals connection problems. If
multiple TSLSs are used the terminal server can have its TSLS specified to ease
licensing issues.

U Double-click on License server discovery mode on the right.

U Select the Use these license servers radio button and enter the name of the
license server.
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2.6. Microsoft Commands

Terminal Services has several commands that aid in managing the terminal server.
Some useful ones are:

Command

Action

change logon

Temporarily disables logons to a Terminal Server

change port

Changes COM port mappings for MS-DOS program
compatibility

change user /install

Puts the server into “Install Mode”

change user /execute

Removes the server from “Install Mode”

Ipconfig

Displays the IP addresses of the network card

Logoff

Logs off a user from a session and deletes the session
from the server

net send username
“message”

Sends a message to a user. username is the NT/2000
user name that the person or terminal is logged in as.
“message” is the text of the message. Quotation marks
are needed for any messages containing a space.

query process

Displays information about processes running on a
Terminal server

query session

Displays information about sessions on a Terminal server

query termserver

Displays a list of all Terminal servers on the network

query user

Displays information about user sessions on a Terminal
server

reset session

Resets a session to known initial values

Shadow Monitors another user's session
Tsdiscon Disconnects a client from a terminal server session
Tsshutdn Shuts down the terminal server in an orderly manner

Commands to launch useful Microsoft programs include:

Command Action
gpedit.msc Launches the Group Policy Editor
tscc.msc Launches the Terminal Services Configuration Console
tsadmin Launches the Terminal Services Manager
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2.7. Alternative Terminal Keystrokes

Certain keystrokes are not available in a terminal session. Microsoft has provided
these alternatives.

Keystroke Function

ALT+PAGE UP Switches between programs from left to right.

ALT+PAGE DOWN Switches between programs from right to left.

ALT+INSERT Cycles through the programs in the order they were
started.

ALT+HOME Displays the Start menu.

CTRL+ALT+BREAK Switches the client between a window and full screen.

CTRL+ALT+END Brings up the Windows 2000 Security dialog box.

ALT+DELETE Displays the Windows menu.

CTRL+ALT+Minus (-) symbol Places a snapshot of the active window, within the

on the numeric keypad client, on the Terminal server clipboard (provides the
same functionality as pressing PrintScrn on a local
computer.)

CTRL+ALT+Plus (+) symbol on Places a snapshot of the entire client window area on

the numeric keypad the Terminal server clipboard (provides the same
functionality as pressing ALT+PrintScrn on a local
computer.)

3. Network

Thin clients and terminal servers need a reliable network.
Make sure that the following network ports are unblocked:

L TCP/2031 - Configuration - Used to pass the configuration from the
ThinManager Server to the thin client.

U TCP/1494 - Citrix - Used by the ICA protocol (if using ICA instead of RDP).
TCP/3389 - RDP - Used by the RDP protocol (if using RDP in v2.4.1 or later).

U TCP/5900 - Shadowing - Used to shadow terminals. This can be changed on
the Shadow Configuration page of the ThinManager Server Configuration
Wizard.

O TCP/ 1758 - Used if the default Multicast is used.
U DHCP - This need configured as needed.

U
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4.

The Thin Client Boot Process

U The terminal is turned on and connects to the network.

U The terminal receives an IP address either through the default DHCP or by
being configured with static IP.

U The terminal connects to a ThinManager Server (defined in Option 066 of
DHCP or by static IP) and downloads its configuration.

U This configuration sends the terminal to the terminal server(s).
ThinManager
5.1. Role of ThinManager

U ThinManager allows the configuration of ThinManager Ready thin clients.

U A ThinManager Ready thin client needs to connect to a ThinManager Server
and receive its configuration.

U This configuration sends the ThinManager Ready thin client to a terminal
server(s) to start a session and run.

U ThinManager allows an administrator to monitor and manage the thin client
system.

U ThinManager provides security to the thin client system.

5.2. ThinManager Installation
U Install on a server or a workstation.
U It is not required to be on the terminal server.

U Installation through Add/Remove Programs is required for a terminal server
installation and is recommended on other computers.

U ThinManager gives three checkboxes for installation. Normally all three are
selected.

o ThinServer is the engine that runs the program.

o ThinManager is the interface that allows control of the ThinServer
engine.

o ThinManager Tools are additional tools like touch screen calibration.

5.2.1. ThinManager versus ThinServer

U The ThinManager program is composed of two parts, a ThinServer engine and
a ThinManager interface.

U ThinServer is the engine that does the work. It supplies the firmware, controls
SmartSession, and holds the licenses and configuration.

U ThinManager is the interface used to control and configure the ThinServer.
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5.3. Redundant ThinManagers

Because each ThinManager Ready thin client needs to contact ThinManager to
retrieve its configuration the use of a second redundant ThinManager Server can be
useful to prevent downtime due to the loss of the primary ThinManager Server.
Redundant ThinManager Servers should be synchronized so that it doesn’t matter
which ThinManager Server the thin client boots from.

Q

5.3.1. Failover versus Redundancy

A ThinManager Ready thin client needs to connect to a ThinManager Server
and receive its configuration.

This configuration sends the ThinManager Ready thin client to a terminal
server(s) to start a session and run.

Redundancy describes having two ThinManager Servers so that a
ThinManager Ready thin client can always find a ThinManager Server to boot
from and receive its configuration.

Failover describes having multiple terminal servers that the thin client is
assigned to so that it always has a terminal server it can connect and start a
session.

5.3.2. Single ThinManager
Install ThinManager on a single computer.

Install all needed licenses on this computer.

5.3.3. Full Redundancy

Full Redundancy uses two synchronized ThinServer engines and has two
ThinManager interfaces for control on either computer.

Q
Q

Install ThinManager on two computers.

Auto-synchronize the two ThinManager Servers as described in section 5.3.5
so that it doesn’t matter which ThinManager Server the thin client boots from.

Purchase and install identical sets of licenses on each computer.

Configure each ThinManager Ready thin client to boot from both ThinManager
Servers.

5.3.4. Mirrored Redundancy

Mirrored Redundancy uses two synchronized ThinServer engines but only allows the
ThinManager interface to run on the designated primary ThinManager Server.

Q

a
a

Install ThinManager on two computers. Designate one as the Primary
ThinManager Server and the other as the Secondary ThinManager Server.

Purchase mirrored licenses.

Auto-synchronize the ThinManager Servers so that the Install IDs of both
ThinManager Servers are displayed in the Licensing Window (Install>Licenses
on the ThinManager menu bar).
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6.

o000 O

(M

Activate the Mirrored License using the Install IDs from the Primary and the
Secondary ThinManager Servers.

A mirrored license can be installed with just the primary install ID and
reactivated with the secondary if the secondary is built at a later time.

Add the license on the Primary ThinManager Server. ThinManager will transfer
the backup license to the Secondary ThinManager Server.

Configure each ThinManager Ready thin client to boot from both ThinManager
Servers.
5.3.5. Auto-Synchronization

Open the ThinManager Server List Wizard by selecting Manage> ThinManager
Server List from the ThinManager menu bar.

Select the Automatic Synchronization checkbox on the Auto-synchronization
Selection window.

Define two ThinManager Servers on the ThinManager Server List page by
selecting the Add Server button.

Define the primary and secondary ThinManager Servers by selecting the Edit
button and adding the server name and IP address.

Select the Finish button to accept the change.

5.3.6. Manual Synchronization

Open the ThinManager Server List Wizard by selecting Manage> ThinManager
Server List from the ThinManager menu bar.

Leave the Automatic Synchronization checkbox on the Auto-synchronization
Selection window unchecked.

Define the ThinManager Servers on the ThinManager Server List page by
selecting the Add Server button.

Close the ThinManager Server List Wizard by selecting the Finish button.
Select Manage>Synchronize Configuration from the ThinManager menu bar.
Highlight the primary ThinManager Server in the Configuration Source list.

Highlight the secondary ThinManager Server in the Configuration Destination
list.

Select Next twice to confirm the synchronization choices.

Select Finish to initiate the synchronization. The configuration from the
primary ThinManager Server will overwrite the configuration on the secondary
ThinManager Server.

ThinManager Licensing

ThinManager requires a license for each terminal that connects through
ThinManager. These are assigned when the terminal retrieves its configuration.

Q

Licenses are activated through the ThinManager web site.
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U The activation process requires two numbers, a License Number and an
Installation ID.

U The License Number is the purchased “paper” license.

U The Install ID ties the license to the hardware and is found on the Licensing
Window by selecting Install>Licenses from the ThinManager menu bar.

U The downloaded license file is installed through ThinManager.

6.1. License Types
ThinManager has two licensing models, the Enterprise with unlimited connections
and the Standard with 5, 10, and 25-connection packs.

6.2. Enterprise Licenses

U Enterprise Licenses provide unlimited connections of terminals and full
redundancy.

U They are available as Enterprise Server and Enterprise Site, with a Plus
version of each.
6.2.1. Enterprise Server

U Enterprise Server provides licenses for two ThinManager Servers for full
redundancy.

U The redundant ThinManager Servers are licensed like Mirrored Redundancy,
with the Install IDs from both ThinManager Servers. Unlike Mirrored
ThinManager Servers, each ThinManager Server can run the ThinManager
interface for configuration and control.

U ThinManager Ready thin clients should be configured to boot from both
ThinManager Servers

U The two ThinManager Servers should be auto-synchronized so that the
configurations are the same. See section 5.3.5.

6.2.2. Enterprise Site

U Enterprise Site allows a customer to install as many ThinManager Servers as
desired on one site.

U The Enterprise Site is a single license number that can be installed on many
computers at that site.

U Redundant pairs of ThinManager Servers are recommended for full
redundancy.

U Enterprise Site allows departmental control by having multiple redundant
pairs of ThinManager Servers.
6.2.3. Enterprise Plus

U Enterprise Plus adds unlimited SmartSession and all licensed modules like
MultiMonitor, Instant Failover, and MultiSession, to the Enterprise License.

U Enterprise Plus doesn’t add WinTMC or TermSecure licenses.
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6.3. Standard Licenses

a
a

Q

Standard Licenses provide licenses in packs of 5, 10, and 25 connections.
Full Redundancy requires a matched set of licenses on each ThinManager
Server.
Standard Licenses include such licenses as:
Terminal o Instant Failover o SmartSession
Connections o  MultiMonitor o MultiSession
WinTMC o Share Keyboard and o Redundant Ethernet
TermSecure Mouse

o Terminal Shadow

6.4. ACP License Account

Q

Q

Q

ThinManager licenses are activated at the ThinManager website at
www.thinmanager.com. A License Activation link will be prominently displayed
on the main page.

Each user needs to register on the License Activation site by creating an
account with contact information for the user. This user account allows the
user to activate licenses.

Licenses should be activated in the name of the end customer and not the
name of a system integrator or consultant.

Once the account is created the password of the account will be e-mailed to
the e-mail address defined in the account.

6.5. License Activation

Q

Q

ThinManager licenses are activated at the ThinManager website at
www.thinmanager.com. A License Activation link will be prominently displayed
on the main page.

The licensee needs to login to the License Activation site with their created
user account.

The logged-in user should select the Activate License link to display the
License Number and the Installation ID fields.

The License Number is the purchased “paper” license.

The Install ID ties the license to the hardware and is found on the Licensing
Window by selecting Install>Licenses from the ThinManager menu bar.

Once both fields are filled and the Submit button is selected, a license file will
be downloaded.

A link is provided on the download page to manually re-start the download if
the browser pop-up blocker prevents the download.

The license file should be saved where it is accessible to ThinManager. Do not
save it into the ThinManager folder.

The downloaded license file is installed through ThinManager. Do not
manually move the license file into the ThinManager folder.
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6.6. License Installation

U Licenses are installed through the Licensing Window of ThinManager that is
launched by selecting Install>Licenses from the ThinManager menu bar.

U Select the Install License button.

U Browse to the downloaded file and select Open. This will install and register
the license.

7. Hardware Configuration

ThinManager Ready thin clients need little configuration at the terminal except an IP
address and the IP address of a ThinManager Server to connect on the network.
Units are shipped using DHCP by default but can be configured to use static IPs.

7.1, IP Addressing
711, DHCP Only

U ThinManager Ready thin clients are set by default to use DHCP to receive
their IP address.

U The DHCP server needs Option 066 - Boot Server Host Name configured to
list the IP address of the ThinManager Server. Redundant ThinManager
Servers can be listed, separated by a space.

See Hybrid IP (DHCP & Static) in section 7.1.3 for another method.

U Launch the Scope Options page by opening the DHCP Server, highlighting the
Scope Options, and selecting Action>Configure Options.

U Check the 066 Boot Server Host Name checkbox, enter the ThinManager
Server IP address in the String value, and select the OK button field.

U Redundant ThinManager Servers can be defined by listing the IP addresses of
both, separated by a space.

L Set the Conflict detection attempts on the DHCP Properties, Advanced tab of
the DHCP Server to one or more.

7.1.2. Static IP Only

U ThinManager Ready thin clients can be configured to use a static IP by
pressing the space bar during the thin client boot when the “Press Any Key to
Configure IP Addresses” message is displayed.

U Select “A” to define the terminal IP. Enter the desired IP and select the Enter
key.

U Select “B” to define the primary ThinManager Server. Enter the desired IP and
select the Enter key.

U Select “C” to define the secondary ThinManager Server if you have redundant
ThinManager Servers. Enter the desired IP and select the Enter key.

U Select “S” to save the configuration and continue with the boot process.
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7.1.3. Hybrid IP (DHCP & Static)

ThinManager Ready thin clients can be configured to use DHCP to assign the terminal
IP address but use a static IP address for the ThinManager Server. This allows a
DHCP server to be used without configuring Option 066.

U Enter the IP Configuration menu by pressing the space bar during the thin
client boot when the “Press Any Key to Configure IP Addresses” message is
displayed.

U Leave “A” alone to keep it using DHCP for the terminal IP address.

U Select “B” to define the primary ThinManager Server. Enter the desired IP and
select the Enter key.

U Select “C” to define the secondary ThinManager Server if you have redundant
ThinManager Servers. Enter the desired IP and select the Enter key.

U Select “S” to save the configuration and continue with the boot process.

8. ThinManager Configuration
ThinManager uses Wizards to aid in the configuration of the terminals.

The wizards can be run to pre-configure the terminals or the wizards can be
launched automatically when the new terminal is connected to ThinManager for the
first time.

Note: If in doubt, the default settings are your friends.
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8.1. Terminal Configuration

Q

Launch the Terminal Configuration Wizard by selecting Edit>Add Terminal
from the ThinManager menu or by right-clicking on the Terminals branch of
the tree and selecting Add Terminal. If a terminal is connected to
ThinManager without a configuration it will launch the wizard automatically.

Proceed through the pages of the wizard. The highlights are:

Q

Q

Terminal Name - Enter the desired name of the terminal. This name should be
15 characters or less.
Add the terminal to a group, if desired, by selecting the Change Group button.

Terminal Hardware - Select the hardware make and model. This is optional,
as the terminal will correctly identify itself when it connects to ThinManager.
WinTMC clients need to use GENERIC/PersonalComputer in the Make/Model
drop-down.

Terminal Options - Shadow access can be controlled in the Shadowing
section.

Terminal Server Specification — Choose whether the terminal will connect to
individual terminal servers or will use Application Groups. Selecting Use
Application Groups will allow the use of MultiSession, MultiMonitor, and
TermSecure.

Terminal Connection Type - Choose the default Remote Desktop Protocol
unless Citrix is installed and being used.

Terminal Server or Application Group Selection — Send the terminal to specific
terminal servers or Application Groups by moving them to the Selected
Terminal Servers or Selected Application Groups list on the right. If Terminal
Servers/Application Groups haven’t been defined then select the Edit Server
List/Edit Application Groups button to launch the needed configuration wizard.

Terminal Interface Options and Hotkey Configuration — A terminal using
multiple Application Groups needs a method to switch between sessions.
These are configured on these two pages (Not applicable when using
individual terminal servers).

Log In Information - Enter a valid Windows user name and password into the
Username and Password fields if you want the terminal to automatically login
when it connects to the terminal server.

If you want the terminal to automatically launch a program instead of the
desktop when using individual terminal servers, add the path to the program
in the Initial Program field.

Video Resolution - Set the desired video resolution for the terminal.

Module Selection - Add any modules that are needed by selecting the Add
button. See Modules in section 11 for details.

ThinManager Server Monitor List — You can have the terminal send the
monitoring status to both ThinManager Servers when using redundancy by
listing both ThinManager Servers in the Selected ThinManager Server list.
Define your ThinManager Servers by selecting the Edit Server List button on
the page.

This is done automatically when using Auto-synchronization.

ThinManual - The Abridged ThinManager Guide
- 17 -



Q

Q

Monitoring Configuration — This sets the rate at which the terminal polls the
terminal server to determine if the terminal server is available for
connections.

If the wizard was launched when the terminal connected to ThinManager it
will continue to boot and login as defined once the Finish button is selected. If
the wizard was run as a pre-configuration, this profile will be available for
selection when new hardware is added.

8.2. Group Configuration

U

Q
Q

Terminals can be organized by adding them to a Terminal Group.
Groups can be nested into other Groups.

A Terminal Group is created by selecting Edit>Add Terminal Group from the
ThinManager menu. The Group Configuration Wizard resembles the Terminal
Configuration Wizard with the addition of the Group Setting checkbox.

A property that is set as Group Settings is applied to everybody in that group.

Terminals can join a group by the selection of the Change Group button on
the Terminal Name page of the Terminal Configuration Wizard.

8.3. Terminal Server Configuration

Q

Terminal servers are defined in the Terminal Server Wizard. This can be
launched by right-clicking on the Terminal Server branch of the ThinManager
tree and selecting Add Terminal Server or by selecting the Edit Server List
button on the Terminal Server or Application Group Selection page.

Proceed through the pages of the wizard. The highlights are:

Q

Q

Q

Terminal Server Name - Enter the Microsoft computer name in the Terminal
Server Name field.

Terminal Server Name - Enter the IP address in the Terminal Server IP field
or use the Discover button to automatically fill in the IP address.

Terminal Server Name - Enter the user name and password for an
administrative account on the terminal server into the User Name and
Password field to allow ThinManager to import the Terminal Services Manager
information into ThinManager. Select the Next button to continue.

Terminal Server Capabilities - Select Available for SmartSession Groups if the
terminal server has a SmartSession license and will be used for
SmartSession. Select the Next button to continue.

Data Gathering - Select a Data Gathering Interval. This is the frequency that
ThinManager polls the terminal server for the Terminal Services Manager
information. Select the Next button to continue.

SmartSession Configuration - This allows the SmartSession parameters to be
changed from the defaults.

Note: If in doubt, the default settings are your friends.
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8.4. Application Group Configuration

Terminal Server Groups were renamed to Application Groups in ThinManager 3.2.

Application Groups can be configured as two types:

Terminal Services - This is the tradition Application Group that allows a

terminal to start a session on a terminal server.

Terminal Shadow - This Application Group allows terminal-to-terminal

shadowing. See Terminal Shadow Application Groups in section 13.2.

Q

Application Groups are defined in the Application Group Wizard. This can be
launched by right-clicking on the Application Group branch of the
ThinManager tree and selecting Add Application Group or by selecting the Edit
Application Groups button on the Terminal Server or Application Group
Selection page.

Select the type of application group desired in the Type of Application Group
drop-down.

8.4.1. Terminal Services Application Group

Proceed through the pages of the wizard. The highlights are:

Q

Q

Group Name - Select Terminal Services in the Type of Application Group drop-
down.

Group Name - Enter the name of the Application Group in the Group Name
field.

Application Group Options = Select the Allow group to be tiled checkbox if you
want to use SessionTiling. See section 14.6.

Application Group Options = Select the Allow group to be moved
(MultiMonitor) checkbox if you want be able to move the session from screen
to screen on a MultiMonitor unit. See 14.1.

Group Options = Select the SmartSession Group checkbox if you want to load
balance the terminal servers in the Application Group.

Group Options - Select the Application Link Group checkbox if you want the
Application Group to run a specific program instead of a desktop.

Group Options - Select the Instant Failover checkbox if you want to use
Instant Failover within the terminal servers of the group.

Application Group Members - Select the terminal servers that should be used
by the Application Group by moving the desired terminal servers into the
Selected Terminal Servers list. Select the Edit Server List button to launch the
Terminal Server Configuration Wizard if you need to define terminal servers.

SmartSession Settings - If the Application Group is a SmartSession group you
can change the SmartSession settings from the defaults, if needed.

AppLink - Enter the path to a program in the AppLink Path field if you want
the Application Group to run a specific program instead of a desktop.

Select the Finish button to complete the Application Group configuration.
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8.4.2. Terminal Shadow Application Group

Proceed through the pages of the wizard. The highlights are:

Q

Q

9.

Group Name - Select Terminal Shadow in the Type of Application Group drop-
down.

Group Name - Enter the name of the Application Group in the Group Name
field.

Application Group Options = Select the Allow group to be tiled checkbox if you
want to use SessionTiling. See section 14.6.

Application Group Options - Select the Allow group to be moved
(MultiMonitor) checkbox if you want be able to move the session from screen
to screen on a MultiMonitor unit. See 14.1.

Terminal Shadow Application Group - Leave the All Terminals Available
checkbox selected to allow any terminal to be shadowed or un-select it and
use the Add button to add one or more terminal to the list or available
terminals to shadow.

Terminal Shadow Application Group - Leave the Interactive Shadow checkbox
selected to allow the user to control the shadowed session or un-select it to
limit a user to viewing the session.

MultiSession

MultiSession allows a user to run several Application Group sessions from one
terminal. These will be cascaded on the terminal.

MultiSession, when used with AppLink, is an easy way to deploy desired applications
while preventing access to unauthorized programs.

9.1. MultiSession Changes in ThinManager 3.2

Q
Q

MultiSession is now licensed by the terminal and not by the terminal server.

Terminal servers and Application Groups no longer need to be configured for
MultiSession. Adding two or more Application Groups to a terminal enables
MultiSession.

9.2. Configuring the Terminal for MultiSession

Q

Q

MultiSession requires that terminals use Application Groups. Select Use
Application Groups on the Terminal Server Specification page of the Terminal
Configuration Wizard.

Select two or more Application Groups on the Terminal Server or Application
Group Selection page of the Terminal Configuration Wizard.

The terminal will need an available MultiSession license.

The terminal needs a method to switch between sessions. This is configured
on the Terminal Interface Options and Hotkey Configuration pages of the
Terminal Configuration Wizard. See section 9.3.

If the terminal is set to auto-login then it will auto-login to the MultiSession
sessions. An Application Group can be set to force manual logins for
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authentication by unselecting the Allow Auto-Login checkbox on the Group
Options page of the Application Group Wizard.

An Application Group can use a different login than the terminal by using the
Override button on the Terminal Server or Application Group Selection page
of the Terminal Configuration Wizard.

Instant Failover can be used within an Application Group. If the Instant
Failover checkbox on the Group Options page of the Application Group Wizard
is selected then the terminal will start two sessions of that application used by
the group. If one server fails the terminal will instantly switch to the backup
session. The Instant Failover module should not be used with Application
Groups.

9.3. Switching Between Sessions

Q

10.

Each terminal that uses MultiSession should be configured to switch between
sessions on the Terminal Interface Options and the Hotkey Configuration
pages of the Terminal Configuration Wizard. At least one method must be
used.

Terminal Interface Options - Show Group Selector on Terminal will display a
drop-down menu on the terminal’s screen. The default auto-hide mode can be
removed by selecting the Selector Options button.

Terminal Interface Options — Enable Tiling will tile the sessions to allow a
visual selection of a session. See section 14.6.

Terminal Interface Options - Screen Edge Selection will switch between
sessions when the mouse is moved to the left or right edge.

Hotkey Configuration - Enable Group Hotkeys will allow keystrokes to switch
the session displayed. The default CTL+Page Up/Down can be changed by
selecting the Change Hotkeys button.

SmartSession

SmartSession provides load balancing among designated terminal servers.

10.1. Configuring the Terminal Server

Q

Q

Terminal servers are configured to use SmartSession by selecting the
Available for SmartSession Groups checkbox on the Terminal Server
Capabilities page of the Terminal Server Wizard.

SmartSession requires that ThinManager be able to pull memory, CPU, and
session data from the terminal server. This requires the username and
password from a valid Windows administrator account to be entered in the
Username and Password fields of the Terminal Server Name page of the
Terminal Server Wizard.

The frequency of the data polling is set on the Data Gathering page of the
Terminal Server Wizard.

The SmartSession Configuration page allows the ranges of the CPU, Memory,
and Session count to be adjusted. (The defaults are your friends).
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Q

Each terminal server configured will require a SmartSession license in
ThinManager. The SmartSession license applies to the terminal server and not
the terminal. The license is assigned when the Available for SmartSession
Groups checkbox is selected.

10.2. Configuring the SmartSession Application Group

Q
Q

11.

SmartSession load balancing uses Application Groups.

An Application Group becomes load balanced when the SmartSession Group
checkbox on the Group Options page of the Application Group Wizard is
selected.

Only terminal servers that have been configured to use SmartSession will be
available for selection on the Application Group Members page of the
Application Group Wizard.

ThinManager polls the SmartSession terminal servers and calculates a Server
Rank number based on the CPU, Memory, and Session resources used. A
terminal connecting to a SmartSession Application Group will be sent by
ThinManager to the terminal server with the most available resources as
defined by the lowest server rank number.

The weight of the SmartSession values can be adjusted on the SmartSession
Settings page of the Application Group Wizard.

The Server Rank number for the SmartSession servers can be displayed by
highlighting a SmartSession Application Group in the ThinManager tree and
selecting the Server Rank tab in the Details pane.

10.2.1. SmartSession Queuing

SmartSession Queuing allows ThinManager to control the rate that terminals
connect to the terminal servers to prevent the server CPU from becoming
overloaded and slowing down the session connection process.

When a CPU reaches the maximum CPU Utilization, as defined on the
SmartSession Configuration page of the Terminal Server Wizard, ThinManager
will delay other terminals from connecting until the CPU utilization returns to
a normal level or the maximum Queuing Time on the SmartSession Settings
page of the Application Group Wizard is reached.

Modules

Modules are features or programs that aren’t needed to run a basic thin client but
can be added to expand the functions.

These include screen savers, touch screen drivers, sound modules, and others. Most
are free to use but a few require a license to use.

Q

Q

Modules are installed on the Module Selection page of the Terminal
Configuration Wizard.

Select the Add button to add a module.

Select the desired module from the list and select the OK button. The
modules can be sorted by module type to filter the selections.
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U Some modules have configurable parameters. To change them highlight the
added module in the Installed Module window of the Module Selection page
and select the Configure button to launch the Module Properties window.

U Highlight the desired parameter to activate the Value field. Use the drop-
down to change the setting them select the Set button to apply the parameter
change. Select the Done button when all the parameters are set.

U Select the Finish button to apply the changes and restart the thin client to
send the configuration change to the thin client.

11.1.  Updating Modules

U New modules can be downloaded from the ThinManager web site at
www.thinmanager.com/support/downloads.shtml#modules.

U Register the new module by selecting Install>Modules from the ThinManager
menu bar and selecting the Install Module button. Browse to the downloaded
module and select the Open button. This will add the module to the list of
available modules.

12. WinTMC

WinTMC is a Windows client that can be installed on PCs but is controlled through
ThinManager.

12.1. WinTMC Advantages

O WinTMC can convert PC to a terminal services client reducing local
maintenance of applications.

U PC becomes managed by ThinManager, allowing failover, Instant Failover,
MultiSession, and SmartSession functions.

U Applications that aren’t terminal services compliant like AutoCAD can be run
locally while gaining management benefits from running other applications on
terminal servers.

12.2. WinTMC Disadvantages

U The PC that WinTMC is installed on still requires installation and maintenance
of its operating system.

U Most modules don’t work because ThinManager doesn’t control the operating
system. These functions must be setup and controlled using the PC operating
system. These include:

o Touch screen drivers
o Sound drivers

o Local storage

o Mouse

o Screen savers

Instant Failover is supported by WinTMC. TermSecure is supported by
WinTMC v2.0.
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12.3. WInTMC Installation

a
a
Q

Install the WinTMC application on the desired PC.
Using the Add/Remove Programs tool is recommended for installations.
WinTMC allows two options during installation:

o WinTMC is the WinTMC client needed to turn the PC into a terminal.

o WinTMC Shadow Service is needed to shadow a WinTMC client. If this
program is installed, the PC can be shadowed from ThinManager even
if the WinTMC client is inactive.

12.4. WinTMC Configuration on the Client

Q

Once installed, launch the WinTMC program from the Windows Start menu or
from a desktop icon.

Select the Configure button on the splash screen.

Enter the IP address of the ThinManager Server(s) in the Enter new
ThinManager Server Name or IP Address field and select the Add button.

Select the OK button to connect to the ThinManager Server.

The Terminal Replacement Dialog window will display any off-line terminals
and a Create a new terminal button. Select a pre-created terminal to assume
an established configuration or select the Create a new terminal button to
launch the Terminal Configuration Wizard for that WinTMC client on the
ThinManager Server.

12.5. WinTMC Configuration in ThinManager

Q

Q

Q

Q
13.

Pre-create a WinTMC client by launching the Terminal Configuration Wizard by
selecting Edit>Add Terminal from the ThinManager menu bar. The
configuration is similar to thin clients with a few exceptions.

Add the computer name for the terminal name in the Terminal Name page of
the wizard.

Select GENERIC for the Make/OEM and PersonalComputer for the Model on
the Terminal Hardware page of the wizard.

Select the video resolution on the Video Resolution page. The default is
FullScreen.

Select the Finish button when the configuration is complete.

Shadowing

Shadowing allows a user to view a terminal. It is available in two forms:

Terminal Shadowing through ThinManager.

Terminal-to-terminal shadowing through Terminal Shadow Application

Groups.
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13.1. ThinManager Shadowing

Q

Q

Terminal Shadowing through ThinManager allows an administrator to see
what is displayed on a terminal’s screen.

A terminal is shadowed by highlighting the terminal in the ThinManager tree
and selecting the Shadow tab on the Details pane.

To shadow a user must be either a member of the Administrators Windows
user group or a member of a Windows user groups that was granted
permission to shadow on the ThinManager Security Groups page of the
ThinManager Server Configuration Wizard.

Shadow settings are configured on the Terminal Options page of the Terminal
Configuration Wizard. The terminal can be set to block shadowing (NO), ask
user permission first (ASK), warn the user first (WARN), or shadow
immediately (YES)

Interactive Shadow allows the administrator to control the shadowed session.
This can be allowed/disallowed on the Terminal Options page of the Terminal
Configuration Wizard. It can also be turned off/on by selecting
RemoteView>Interactive Shadow on the ThinManager menu.

WinTMC requires that the WinTMC Shadow Service be installed on the client
PC. Once the PC has been connected to ThinManager the PC can be shadowed
even if WinTMC is not running.

13.2. Terminal Shadow Application Groups

Q

Q

14.

Terminal-to-terminal shadowing through Terminal Shadow Application Groups
allows any user on a terminal with the Terminal Shadow group to shadow a
terminal that is in the Terminal Shadow group. See section 8.4.2 for
configuration.

The terminal that is configured to use a Terminal Shadow Application Group
needs to have a Terminal Shadow license available when it boots.

Additional Topics

14.1. MultiMonitor

Q

Q

MultiMonitor allows a single ThinManager Ready thin client to have up to 5
monitors attached at the same time.

The monitors can be combined into larger “spanned” screens (double-
wide/triple-wide/etc.) or run as individual single-monitor “screens”.

Each monitor can be of a different video resolution or use a different touch
screen. However monitors that are combined to form a spanned screen must
have the same resolution.

MultiMonitor requires a MultiMonitor license or an Enterprise Plus license. One
license covers the thin client. You don’t need a license per monitor.

MultiMonitor requires the use of Application Groups.

MultiMonitor requires the use of MultiSession.
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Q

14.1.1. Configuring MultiMonitor
MultiMonitor is configured in the Terminal Configuration Wizard.

Terminal Hardware page- Select the Make and Model of the MultiMonitor
ThinManager Ready thin client.

Terminal Server Specification page - Select Use Application Groups.
Terminal Server Specification page - Select Enable MultiMonitor.

MultiMonitor Video Settings page — Select the Number of Monitors and the
video resolution of each.

Monitor Layout page - Select the physical layout of the monitors in the
Choose your monitor layout window. The Main Monitor is the monitor that will
display login and message windows.

Monitor Layout page - Select how the monitors will be combined in the
Choose your screen layout window. Choose whether the monitors are
combined as “spanned” or kept individual as “screened”. The TermSecure
Initial Screen is the monitor that will display TermSecure login and message
windows if TermSecure is used.

Application Group Selection page - Select which Application Group(s) will be
displayed on which screen by highlighting the desired Application Group and
selecting the appropriate arrow.

Screen Options page - This configures options like the ability to move
sessions, which monitor in a spanned group is the main monitor, and how
MultiSession switching should take place.

Hotkey Configuration page - This configures hotkey options for MultiSession
and SessionTiling.

14.2. Reports

Q

Q

ThinManager has reports that can be displayed to show events and
configurations.

Selecting View>Reports will allow the administrator to select what reports will
be displayed.

Reports are shown by highlighting an item in the ThinManager tree and
selecting the Report tab in the Details pane.

New reports can be added by selecting Install>Reports>Install in the
ThinManager menu. Each report has a Report Template and a SQL Query
component.

Reports can be run automatically and saved as *.html files using the
Scheduler on the System Schedule page of the ThinManager Server
Configuration Wizard.
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14.3. Touch Screens

U Touch screens are activated by adding the appropriate Touch Screen module
on the Installed Modules page of the Terminal Configuration Wizard.

U The module needs to match the make of the touch screen controller. The
make of the monitor is incidental.

U Touch screen parameters cam be changed by highlighting the module on the
Installed Modules page of the Terminal Configuration Wizard and selecting the
Configure button.

U Touch screens can be configured so that a touch that is held will count as a
right click or will initiate the calibration program.

U The terminal can be calibrated by highlighting the terminal in the
ThinManager tree and selecting Tools> Calibrate Touch Screen on the menu.

O A different touch screen can be applied to each monitor in a MultiMonitor
configuration, if needed.

14.4. Event Log

U ThinManager has an event log that can be displayed by highlighting an item in
the ThinManager tree and selecting the Event Log tab in the Details pane.

U The Event Log is configured on the Historical Logging page of the
ThinManager Server Configuration Wizard. The events to track and the
duration of the event log are configurable.

U The Event Log can be backed up automatically using the Scheduler on the
System Schedule page of the ThinManager Server Configuration Wizard.

14.5. Security

ThinManager is designed to increase security.

U ThinManager can be run only by administrators or members of Windows user
groups that have been given permission on the ThinManager Security Groups
page of the ThinManager Server Configuration Wizard.

U Terminals can be configured to login automatically. This obscures the
username and password so that a user doesn’t know the account credentials
to try to access other resources.

U AppLink can limit a user to specific programs and block access to the desktop
or unauthorized programs.

U The Key Block module can be set to trap undesired keystrokes.

U TermSecure can be used to provide addition access control and management.

14.6. Scheduling

U The Schedule button on the Terminal Options page of the Terminal
Configuration Wizard allows a terminal to be disabled, enabled, or rebooted
automatically on a schedule.
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Q

Q

The Schedule button on the System Schedule page of the ThinManager Server
Configuration Wizard allows the configuration to be backed up or reports run
automatically on a schedule.

A weekly backup the configuration with System Schedule tool is
recommended.

14.7. SessionTiling

Q
Q

Q

15.

The sessions started using MultiSession can be tiled on a terminal to display
all sessions at once.

This might be to monitor all the sessions at once or as a visual selection aid
on terminals with touch screens that lack a keyboard for hotkey switching.

Selecting the Enable Tiling checkbox on the Terminal Interface Options page
of the Terminal Configuration Wizard enables SessionTiling. The Tiling Options
button allows the tiling parameters to be configured.

Failover and Instant Failover

15.1. Definitions

15.1.1. Failover versus Redundancy

Redundancy describes having two ThinManager Servers so that a
ThinManager Ready thin client can always find a ThinManager Server to boot
from and receive its configuration.

Failover describes having multiple terminal servers that the thin client is
assigned to so that it always has a terminal server it can connect to and start
a session.

15.1.2. Failover Explained

In Failover a ThinManager Ready thin client is assigned to a list of terminal
servers and will connect to the first one on the list.

The ThinManager Ready thin client will detect if that terminal server fails and
will connect to the next terminal server on the list. This normally takes 10-20
seconds.

Once the thin client connects to the backup terminal server it will login and
launch its application. The application launch can take 5 seconds to 3 minutes
depending on the application and the terminal server load.

All versions of ThinManager provide the failover function for free.

15.1.3. Instant Failover Explained

Instant Failover configures the ThinManager Ready thin client to connect to
two terminal servers and launch a session on each at the same time.

The terminal should be configured to auto-login and launch an initial program
to gain the full benefits of Instant Failover.

U The sessions are cascaded on the terminal monitor.
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Q

Q

A failure of the primary terminal server will cause the terminal to switch to
the backup session. Since the session and application are already initialized
this takes just a second.

If the terminal is assigned to three or more terminal servers the terminal will
then start a second session on the next available terminal server.

Instant Failover can be configured so that the user can switch between active
sessions.

Instant Failover requires an Instant Failover license for each terminal.

15.2. Failover

Q

Standard failover is configured by providing the ThinManager Ready thin client a list
of terminal servers for connection.

The method of failover differs if the terminal is using individual terminal servers or
Application Groups, as configured on the Terminal Server Specification page of the
Terminal Configuration Wizard.

Open the Terminal Configuration Wizard by double-clicking on the terminal
icon in the ThinManager tree. Navigate to the Terminal Server Specification
page and select Use Application Groups or Select Individual Terminal Servers.

15.2.1. Terminals using Individual Terminal Servers

Add two or more terminal servers to the Selected Terminal Servers list on the
Terminal Server or Application Group Selection page. The terminal will
connect to the terminal servers in the order listed.

The Enforce Primary Terminal Server Connection checkbox, if selected, will
keep a terminal connected to the first terminal server on the list if possible. If
the terminal switches to a backup terminal server it will reconnect to the first
terminal server in the Selected Terminal Servers list when that terminal
server becomes available again.

The Monitoring Interval on the Monitoring Connection page regulates how fast
failover takes place.

The Primary Uptime Delay on the Monitoring Connection page delays the
terminal from switching back to the primary terminal server to allow the
terminal server to finish booting before terminals connect.

15.2.2. Terminals using Application Groups

Failover is configured within an Application Group by adding two or more
terminal servers to the Selected Terminal Servers list on the Application
Group Members page of the Application Group Wizard.

Open the Application Group Wizard by double-clicking on the Application
Group icon in the ThinManager tree.

Add two or more terminal servers to the Selected Terminal Servers list on the
Application Group Members page.

The terminal will connect to the terminal servers in the order listed unless the
Application Group has been configured for SmartSession.
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U Terminals will connect to the terminal servers in a SmartSession group based
on their load, from the lightest to the heaviest load.

U Selecting the Enforce Primary checkbox on the Group Options page of the
Application Group Wizard activates the Enforce Primary function. Enforce
Primary is not available for SmartSession groups.

15.3. Instant Failover

Instant Failover enables a terminal to login and create a session on two terminal
servers so that the backup session is initialized for a quick switch.

Instant Failover is configured differently if the terminal is using individual terminal
servers or Application Groups. This is determined on the Terminal Server
Specification page of the Terminal Configuration Wizard.

A terminal using individual terminal servers uses the Instant Failover Module.

A terminal using Application Groups has Instant Failover configured in the Application
Group.

U Open the Terminal Configuration Wizard by double-clicking on the terminal
icon in the ThinManager tree. Navigate to the Terminal Server Specification
page and select Use Application Groups or Select Individual Terminal Servers.

15.3.1. Terminals using Individual Terminal Servers

U Navigate to the Module Selection page of the Terminal Configuration Wizard.

U

Select the Add button and select the Instant Failover Module.

U Switching between sessions can be configured by highlighting the Instant
Failover Module and selecting the Configure button, highlighting Hot Key
Session Switching, changing the Value drop-down to Enabled, selecting the
Set button, and selecting the Done button.

U Restart the terminal when the configuration is made. The terminal will start a
session on two terminal servers.

U If the primary terminal server fails the terminal will immediately display the
secondary session.
15.3.2. Instant Failover with Application Groups

U Instant Failover is configured within an Application Group for terminals that
use Application Groups.

U The Instant Failover module should not be used with Application Groups.

U Open the Application Group wizard by double-clicking on the Application
Group in the ThinManager tree.

U Navigate to the Group Options page of the Application Group Wizard and
select the Instant Failover checkbox.

U Select two or more terminal servers for the Application Group by adding them
to the Selected Terminal Servers list on the Application Group Members page
of the Application Group Wizard. Select the Finish button to accept the
changes.
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Add the Instant Failover Application Group to a terminal by opening the
Terminal Configuration Wizard for the terminal by double-clicking on it in the
ThinManager Tree.

Navigate to the Terminal Server Specification page and select the Use
Application Groups radio button.

Navigate to the Terminal Server or Application Group Selection page and add
the Instant Failover group to the Selected Application Group list.

Select the Finish button and restart the terminal. The terminal will start two
sessions of that application used by the group. If one server fails the terminal
will instantly switch to the backup session.

ThinManual - The Abridged ThinManager Guide
- 31 -



16. ThinManager Troubleshooting Guide

This is a list of common configuration errors and a guide for fixing them.

Note: When any problem arises, check Downloads at www.thinmanager.com for the
latest firmware. The problem you are experiencing may have already been fixed and
released in a later version of firmware and using the latest version will cure the
current problem. Try applying the latest firmware, and then reboot the thin client to
see if the problem still exists. The current version is backwards compatible to earlier
versions of ThinManager (2.3.1, 2.4, 2.5, 2.6, 3.0, etc.)

16.1. From Power on to Terminal Server Login

1) Powering on the Thin Client
A) No Power
e Check power cable, power supply, and power outlets.
B) No Video
¢ Check video cable and monitor.

Warning: Never go into the thin client BIOS and change the
Integrated Peripherals>Display Status from CRT to LCD. This
changes the video output of the motherboard from the VGA port to a
socket on the motherboard used for integrated LCD panels. Changing
this from CRT will prevent any video from being displayed on a
monitor.

2) Booting - ACP Network Boot Loader
A) Cannot get IP address using DHCP

e Is the ThinManager Ready thin client set to DHCP? They are set to
DHCP by default, but can be changed.

e Is the Thin Client on the same side of the router as the DHCP
server?

¢ Does the DHCP server have addresses to give out?
B) Cannot get IP address using Static IP menu

e Certain models (ThinAdapters and older DC-40-100s with black PS/2
ports) cannot use static IP.

e Static IP hasn't been set. Use the spacebar when the "Select any Key
to Configure IP Settings" is displayed and set the client IP address

3) Cannot Load Firmware
A) Is Thin Client connecting to ThinManager Server?

i) Using DHCP
e Has Option 066 been set to the ThinManager Server IP
Address?

e Is there a link light on the network port?
e Check router address, IP Addresses, and Subnet Mask
i) Using Static IP

e Has the ThinManager Server IP Address been entered in the IP
Configuration Menu?
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B) Is the network blocked?

ThinManager Ready thin client that communicate through routers,

gateways, or firewalls may need some ports opened to allow data flow
through these devices. If the thin client communicates through one of
these and it is having trouble, check to see if these ports are allowed.

The required ports are:
e UDP/4900 - TFTP - Used for the TFTP download of the firmware.

e TCP/2031 - Configuration - Used to pass the configuration from the
ThinManager Server to the thin client.

e TCP/1494 - Citrix - Used by the ICA protocol (if using ICA instead of
RDP).

e TCP/3389 - RDP - Used by the RDP protocol (if using RDP in v2.4.1 or
later).

e TCP/5900 - Shadowing - Used to shadow terminals. This port can be
changed on the Shadow Configuration page of the ThinManager
Server Configuration Wizard.

¢ Ping and DHCP - These need configured as needed.
C) Loads firmware intermittently/slowly
e Check for IP conflicts
e Check cable connections
¢ Make sure ThinManager Server CPU usage is below 100%
4) Thin Client Loads Firmware but shows blue message screen
A) "Please Define on Server"
e Enter ThinManager and define the terminal.
B) "License Not Available"

e Check your license usage in ThinManager. You are out of an ACP-
supplied License.

C) "This Terminal Disabled"
e A ThinManager administrator has disabled this terminal. Re-enable it.
D) "Network Error - Check Network Connections"
e Check the network cable, link light, and network.
E) Was Disabled, but did not go on when Re-enabled.
e Reboot.
F) Terminal Selection menu is shown, but keyboard does not work
e Check keyboard and reboot
e Use PS/2 splitter if the unit has only one PS/2 port
e Switch the mouse and the keyboard if plugged into a PS/2 splitter.
5) Graphical ACP Logo is shown, but boot process stops
A) Does not attempt to connect to the terminal server

¢ Check Terminal Configuration Wizard to make sure a terminal server
is specified
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B) Cannot Connect to Server xxx (0.0.0.0)

e The terminal server doesn't have an IP address configured in the
Terminal Server Configuration Wizard.

e If using DNS, check the terminal server's registration.

e If you are using a Citrix Published Application, you may need to specify
the ICA browser.

C) Cannot Connect to Server xxx (w.x.y.z)

¢ Check the event viewer on the terminal server. If it says "Could not
issue client license", you need a Microsoft Terminal Server Client
Access License (MS TS CAL) and/or a Microsoft Terminal Server
Licensing server.

e Check the Subnet Mask in the ACP Boot Loader on the thin client. If it
is set to 255.255.255.255 instead of 255.255.255.0, it will fail to
connect to the terminal server.

Reboot the thin client and use the spacebar when the "Select any
Key to Configure IP Settings" is displayed. Change the subnet
mask in the ACP Boot Loader menu.

D) Error 50 - Disconnected

e Check the event viewer on the terminal server. If it says "Could not
issue client license", you need a MS TS Cal / MS TS Licensing server.

6) Attempts to connect to terminal server, but dies

Some servers (Dell and its Dellwall.bmp, for example) load a complex
bitmapped background that can interfere with loading. Find the offending
wallpaper file on the console session and renamed it so that it doesn't load at
login

7) Connects to connect to terminal server, but cannot login

Is the user a valid user? Is the password correct?

Does the user have permission to connect through Terminal Services (user
properties in the User Manager)

If logging in to a Windows 2003 terminal server, is the user a member of the
Administrators group or Remote Desktop Users group?

Check the event viewer. If it says "Could not issue client license", you need a
Microsoft TS Cal and or a Microsoft TS Licensing server.

8) Login to Terminal Server prompts for password even though the
username and password are filled in ThinManager

The password may be entered wrong in ThinManager.

Windows 2000 Server is set to always prompt for password at login for RDP
users. Select Programs>Administrative Tools>Terminal Services
Configuration and double click on RDP-tcp Properties in the right-hand
window. Uncheck the Always Prompt for Password checkbox on the
Login Settings tab.
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16.2. Thin Client is Running a Session on the Terminal
Server

9) Disconnects randomly

e Make sure each user is logging on with a unique user name. Windows 2003
will only allow one session per name by default.

e Check the physical network connection.
e Check for a different computer (e.g. a laptop) with the same IP address.

¢ Slow down the Monitoring Interval on the Monitoring Connection page of the
Terminal Configuration Wizard by increasing the timeout and retry values.

10) The session in Windows 2003 requires frequent logins

¢ Turn off the Windows screen saver. User accounts in Windows 2003 use a
secure screen saver by default that requires this frequent login.

11) Mouse works but the application is unresponsive

e Application on terminal server is locked up - kill the application and let the
thin client reconnect to terminal server and restart the application

12) Sound doesn't work
e Make sure that you are using a Windows 2003 terminal server

e Make sure that Audio Mapping is allowed on the Client Settings of the RDP-tcp
Properties in the Terminal Server Configuration Console.

e Make sure that you are using a ThinManager Ready thin client that has sound
capability
e Use the Sound Module for that specific thin client

e Connect a powered speaker to the "Line Out" plug. Line Out isn't amplified so
it requires a powered speaker.

e Properly working sound will play a drip sound at boot.
13) The touch screen doesn't work

e Make sure you are using the right Touch Screen Module for the touch screen
controller.

e Make sure that the serial cable is plugged into the correct serial port
e Make sure that the Touch Screen Module is using the correct baud rate.
14) The touch screen mouse doesn't match the touches.

e (Calibrate the touch screen by highlighting the unit in the ThinManager tree
and select Tools > Calibrate Touch Screen.

15) Changes to the configuration in ThinManager don't show up on the thin
client.

¢ Reboot the thin client. Changes are only set to a thin client at bootup.

16) The configuration of the primary ThinManager Server and the secondary
ThinManager Server are different.
e Synchronize the configurations by selecting ThinManagerServer
>Synchronize in the ThinManager menu bar.

ThinManual - The Abridged ThinManager Guide
- 35 -



17) The terminals in the tree on the primary ThinManager Server show
green while the terminals on the secondary are all red.

e Add both ThinManager Servers to the ThinManager Server Monitor List in the
Terminal Configuration Wizard (then reboot the terminals and synchronize the
ThinManagers as in Number 15) and Number 16).

18) The client is showing the time of the terminal server in a different time
zone and not the local time.

e Use the Time Zone Redirection Module on the client with the local time zone
selected.

e Make sure that the security policy of the terminal server or domain allows it.
Look at Computer Configuration > Administrative Templates>
Windows Components > Terminal Services >Client/Server data
redirection >Allow Time Zone Redirection and set it to Enabled

19) When "Terminal Servers" is highlighted in the ThinManager tree, the
Details pane doesn't show OK for the connections.

A) No login information supplied

e Run the Terminal Server List Wizard and add an administrative user
name and password on the Terminal Server Name page of the
Terminal Server List Wizard.

B) User specified does not have permission to connect

e This indicates that the Terminal Server had an invalid username and
password added on the Terminal Server Name page of the Terminal
Server List Wizard. Run the Terminal Server List Wizard and change
to an administrative user name and password on the Terminal Server
Name page of the Terminal Server List Wizard.

e Use the domain in the Domain field on the Terminal Server Name
page of the Terminal Server List Wizard.

e If notin a domain, try using the terminal server name in the Domain
field on the Terminal Server Name page of the Terminal Server List
Wizard.

C) WTSAPI32.dll connection failed

e This occurs when the terminal server is off or unreachable. Try
pinging the terminal server.

20) The Users, Sessions, and Processes tabs don't show data for a terminal
server

A) No login information supplied

e Run the Terminal Server List Wizard and add an administrative user
name and password on the Terminal Server Name page of the
Terminal Server List Wizard.

B) User specified does not have permission to connect

e This indicates that the Terminal Server had an invalid username and
password added on the Terminal Server Name page of the Terminal
Server List Wizard. Run the Terminal Server List Wizard and change
to an administrative user name and password on the Terminal Server
Name page of the Terminal Server List Wizard.

e Use the domain in the Domain field on the Terminal Server Name
page of the Terminal Server List Wizard.
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e If notin a domain, try using the terminal server name in the Domain
field on the Terminal Server Name page of the Terminal Server List
Wizard.

21) The Users and Sessions tabs show data for a terminal server, but
the Processes tabs shows no data.

Shorten the name of the terminal.

Microsoft truncates the terminal names to 15 characters. The Process
information won't display for terminals with a name longer than 15
characters.

22) When shadowing a client the mouse doesn't work in the shadowed
session.

The user must be logged into the shadowing computer as an administrator or
as a ThinManager Administrator to use interactive shadowing.

The interactive shadow must be checked in RemoteView on the
ThinManager menu.

A terminal using the Share Keyboard and Mouse module will only be
interactive if the mouse is active in that session.
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